Incidents following the new release

Incident Report for Hivebrite Status page

Resolved

This incident has been resolved.
Posted Oct 19, 2017 - 13:28 CEST

Investigating

We are currently investigating this issue.
Posted Oct 19, 2017 - 13:08 CEST