Our Microsoft Azure production server is down
Incident Report for Hivebrite Status
Resolved
This incident has been resolved.
Posted Apr 25, 2018 - 16:06 CEST
Investigating
We are currently investigating the issue with Microsoft.
Posted Apr 25, 2018 - 15:52 CEST